Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Most important DB, not backing up

Matthew Oct 08, 2016 10:10AM CDT

I have tested Minion Backup on a variety of SQL servers at our office, and everything looks great. I tried to roll out on our most mission critical server, and no luck. It is a 3 node Windows 2012 R2 Cluster with Sql 2012 R2. The instance I'm trying to back up has a sing DB in full recovery. I have it set to to a full daily and logs every 10 minutes. The system DBs are backing up fine, but the user DB never backs up. I looked in the Minion.BackupLog table, and it agrees it was skipped. I can't find any detail as to why it was skipped. Any tips on where I can look to find out why?

Up 0 rated Down
Sean McCown Oct 08, 2016 10:28AM CDT MinionWare Agent

Hey Matthew, it sounds like you might be having some scheduling trouble. We’ve had some known issues with schedules that we believe we got worked out in this last release, 1.2.
Try downloading the latest version and see if that clears up your issue. If not, then let me know and I’ll work through other things with you that could be knocking the DB out of the run.
In the meantime if you’d like to send me your Settings tables in excel then I can also start taking a look at them to see if anything jumps out at me.

Also, one of the great things about the new version is the BackupMaster SP has a new test param that lets you see which schedules will be used at any given date and time. So you can use that to see if the schedule is being chosen.
Once you get it downloaded and installed, let me know and I’ll talk you through it.

Up 0 rated Down
Sean McCown Oct 10, 2016 05:39PM CDT MinionWare Agent

Hey Matthew, I haven’t heard back from you on this. Are you still having the issue?

Up 0 rated Down
Matthew Kitchin Oct 11, 2016 04:11PM CDT
Sorry, I just saw this. It didn't email me or anything. I will try it now. IS there another way I can reply to you, or is this it? Please remove my duplicate question I posted.
Up 0 rated Down
Matthew Kitchin Oct 11, 2016 04:17PM CDT
I think I'm already running 1.2 This is from the installs script:

Version 1.2 Fixlist:
• Fixed: Not logging the error properly when you don't have PS scripts enabled. It will now show up in the LogDetails table.
• Fixed: Sometimes @@Servername and the machine name aren't the same. It's the machine name you want to go by, so it now uses SERVERPROPERTY('MachineName').

Version 1.2 New Features:
• New: Currently when a backup fails, the errors are logged to the LogDetails table and the job succeeds. We’ve had feedback from users that they want the job to fail when a backup fails. So now if there are failures or warnings, the job will fail.

*/
Up 0 rated Down
Sean McCown May 08, 2017 08:44AM CDT MinionWare Agent

This was caused by an LS DB that was restored and it kept the LS settings so MB was filtering it out of the backup list.

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
556ca399015f31edc97a62de2771be1a@minionware.desk-mail.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete